Visure Solutions


Support
Login
Start Free Trial

System Requirements

Visure Requirements ALM Platform – System Requirements

The commercial open databases supported by Visure Requirements ALM are the following:

  • Microsoft SQL Server:2008, 2012, 2014,2016,2019
  • ORACLE: 10, 11, 12C,18C
  • Postgres 13, 14

For smaller deployments, with a relatively small number of items (< 5000 items) and concurrent users (< 5 concurrent users) the following databases are currently supported:

  • SQL Server Express
  • Oracle Database Express

These databases have built-in performance restrictions. Visure highly encourages to review these restrictions before deploying them.

The migration between any of these databases is fully supported within Visure Requirements.

Visure Requirements ALM Client

Hardware requirements

Processor:Multicore processor recommended for better performance (INTEL I5 or higher)
Hard Disk Drive:16 GB minimum free space
RAM memory:32 GB recommended

Software requirements

Supported Operating Systems

  • Microsoft Windows Server 2008 / Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012 / Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016
  • Microsoft Windows 7: 32 and 64-bit
  • Microsoft Windows 8: 32 and 64-bit
  • Microsoft Windows 10: 32 and 64-bit
  • Microsoft Windows 11: 32 and 64-bit

Note: it is necessary to log in the system with Administration rights to successfully install the product. In Windows 7 and Windows 8 the installer must be executed using the option “Run as administrator” (right click on the installer and select this option).

Supported ODBC Drivers

Depending on the database engine selected to store the VR repository, the corresponding supported ODBC driver version is required (only 32-bit ODBC drivers are supported):

VersionODBC Supported driversDownload linksFor detailed information,Check the chapter  ODBC Drivers
Microsoft SQL Server2008SQL Native Client 10.0X64 Package
2012SQL Native Client 11.0X64 Package
2014Microsoft® ODBC Driver 11 for SQL Server®X64_Package
2016Microsoft® ODBC Driver 13 for SQL Server®X64_Package
2017/2019Microsoft ODBC Driver 17 for SQL ServerX64_Package
Oracle1010.2.0.5Driver versions with known issues that may cause malfunctions in Visure Requirements 6 ALM:10.1.0.X (all versions with X < 31) 11.2.0.1 (in Windows 7 64-bit and in Windows 8 64-bit) Download
1111.2.0.4
1212.1.0.2
19 C19.3.0.0
Postgres13ANSI64https://www.postgresql.org/download/products/2-drivers-and-interfaces/ > psqlODBC > MSI > ANSI64 > 32 or 64 depending on your needs. I downloaded the generic one.

Visure Requirements ALM License Server

The installation of the Visure License Server is required only if floating licenses are used. Only one Visure License Server installation will be necessary for all Visure Requirements ALM users.

The Visure License Server must be installed in a Windows Server 2008 (32 or 64-bit), Windows Server 2012 (32 or 64-bit), Windows Server 2016 (32 or 64-bit), Windows Server 2019 (32 or 64-bit),  Windows 7 (32 or 64-bit), Windows 8 (32 or 64-bit), Windows 10 (32 or 64 bit) or Windows 11 (32 or 64 bit) with Administration rights.

By default Visure License Server uses port  6200(this can be changed) for communication with client installations, so this port is need to be opened.

Communication Requirements

1 GB/10 GB LAN between the VR clients and the Visure repository. There must be bidirectional communication via TCP/IP between the License Server and the VR clients. For further details on how to install Visure Requirements, please review Visure Requirements ALM System Requirements.
For medium-to-large deployments, a client virtualization solution is recommended. Please contact us to discuss various possibilities.

Top